Bug 3507 - Global #defines don't propagate in version compat.
: Global #defines don't propagate in version compat.
Status: RESOLVED FIXED
: Pike
Core
: 7.5
: All All
: P3 (normal) major
: ---
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2003-09-17 16:45 CET by
Modified: 2003-09-18 19:01 CET (History)
Scrum Prio:
In scrum?: ---
Story included in sprints:
Unplanned in sprints:


Attachments


Description From 2003-09-17 16:45:24 CET
$ pike -DFOOBAR=GAZONK
Pike v7.5 release 12 running Hilfe v3.5 (Incremental Pike Frontend)
> FOOBAR;
Compiler Error: 1:Undefined identifier "GAZONK".
Terminal closed.
$ pike -DFOOBAR=GAZONK -V7.4
Pike v7.5 release 12 running Hilfe v3.5 (Incremental Pike Frontend)
> FOOBAR;
Compiler Error: 1:Undefined identifier "FOOBAR".
Terminal closed.
------- Comment #1 From 2003-09-18 19:02:15 CET -------
Fixed in master.pike 1.300.

Note

You need to log in before you can comment on or make changes to this bug.