Bug 3166 - Failed to encode p-code: "Encoding of efuns is not supported yet."
: Failed to encode p-code: "Encoding of efuns is not supported yet."
Status: RESOLVED FIXED
: Roxen WebServer
RXML Parser
: 2.4
: All Other
: P3 (normal) normal
: ---
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2002-06-28 13:54 CET by
Modified: 2002-07-23 17:26 CET (History)
Scrum Prio:
In scrum?: ---
Story included in sprints:
Unplanned in sprints:


Attachments


Description From 2002-06-28 13:54:09 CET
13:50:27  : Failed to encode p-code entry for "index.xml":
 1m 1.5s  : Encoding of efuns is not supported yet.
          : etc/modules/RXML.pmod/module.pmod (version 1.287):8262:
p_code_to_string(RXML.PCode(RXML.t_html(xml),RXML.TagSet(demolabs,rxml_tag_set)),Configuration(demolabs))
          : /home/anders/SiteBuilder/2.4/handlers/xml/common.pike (version
1.62):374:
xml/handler()->view_xml_or_html(@0=MDFile("/home/anders/Roxen/2.4/demolabs.sb/wa/view/index.xml",rML(Cl)),@1=mapping[1],@2=RequestID(/))
          : /home/anders/SiteBuilder/2.4/handlers/xml/handler.pike (version
1.24):22: xml/handler()->view(@0,@1,@2)
          :
/home/anders/SiteBuilder/2.4/pike-modules/Sitebuilder.pmod/module.pmod
(version 1.162):420: sb_http_file_answer(@0,@2,0)
13:50:27  :
/home/anders/SiteBuilder/2.4/pike-modules/Sitebuilder.pmod/Workarea.pike
(version 1.197):2113:
Workarea(,Site(demolabs:/home/anders/Roxen/2.4/demolabs.sb/))->wa_find_file_low("index.xml",0,1,@3=RoxenModule(demolabs/workarea#0),@2)
 1m 1.5s  :
/home/anders/SiteBuilder/2.4/pike-modules/Sitebuilder.pmod/Workarea.pike
(version 1.197):2342:
Workarea(,Site(demolabs:/home/anders/Roxen/2.4/demolabs.sb/))->wa_find_file("index.xml",0,1,@3,@2)
          : /home/anders/SiteBuilder/2.4/modules/manager/workarea.pike
(version 1.168):747:
RoxenModule(demolabs/workarea#0)->find_file("index.xml",@2)
          : base_server/configuration.pike (version 1.520):1523:
Configuration(demolabs)->low_get_file(@2,0)
          : base_server/configuration.pike (version 1.520):1749:
Configuration(demolabs)->get_file(@2,0,0)
          : base_server/configuration.pike (version 1.520):1712:
Configuration(demolabs)->handle_request(@2)
13:50:27  : modules/directories/indexfiles.pike (version 1.22):59:
RoxenModule(demolabs/indexfiles#0)->parse_directory(@2)
 1m 1.5s  : base_server/configuration.pike (version 1.520):1599:
Configuration(demolabs)->low_get_file(@2,0)
          : base_server/configuration.pike (version 1.520):1749:
Configuration(demolabs)->get_file(@2,0,0)
          : base_server/configuration.pike (version 1.520):1712:
Configuration(demolabs)->handle_request(@2)
          : protocols/http.pike (version 1.370):1917:
RequestID(/)->handle_request()
          : base_server/roxen.pike (version 1.798):588:
roxen->handler_thread(2)
------- Comment #1 From 2002-07-23 17:26:59 CET -------
The fix made in etc/modules/RXML.pmod/module.pmod:1.288 should address this.

Note

You need to log in before you can comment on or make changes to this bug.