Bug 2117 - Backtraces in the debug log when using ssl on nt
: Backtraces in the debug log when using ssl on nt
Status: RESOLVED FIXED
: Pike
Modules
: 7.2
: All Windows
: P3 (normal) normal
: ---
Assigned To:
:
:
:
  Show dependency treegraph
 
Reported: 2001-08-31 19:06 CET by
Modified: 2001-09-11 20:26 CET (History)
Scrum Prio:
In scrum?: ---
Story included in sprints:
Unplanned in sprints:


Attachments


Description From 2001-08-31 19:06:34 CET
I get backtraces like these when I connect with ssl on nt:

Cannot access global variables in destructed object.
/Program Files/Roxen Internet Software/WebServer/server-
2.2.172/protocols/http.pike:1017: unknown function(0)
pike/lib/pike/modules/SSL.pmod/sslfile.pike:395: ssl_close_callback(0)
pike/lib/pike/modules/Stdio.pmod/module.pmod:698: Stdio.File
("socket", "194.52.182.230 1054", 777 /* fd=-1 */)->__stdio_read_callback()

There are no effects (like broken images) on the client side.
------- Comment #1 From 2001-09-06 18:31:24 CET -------
Solaris-8 X86, lain.roxen.com, Roxen 2.2.195

File destructed while in file->write.
Unknown program:
write("\27\3\1\4\210\355QU\343F%\202o\211\205\304"+[1133]+"\307
P?\22\313\373\367(\376N\332\26@\2n\22")
module.File: Stdio.File("socket", "194.52.182.122 54083", 777 /* fd=-1
*/)->writ
e()
pike/lib/pike/modules/SSL.pmod/sslfile.pike:352: ssl_write_callback(0)
pike/lib/pike/modules/Stdio.pmod/module.pmod:702: Stdio.File("socket",
"194.52.1
82.122 54083", 777 /* fd=-1 */)->__stdio_write_callback()

( $Id: sslfile.pike,v 1.35 2001/08/25 18:26:45 noy Exp )
------- Comment #2 From 2001-09-11 20:14:03 CET -------
*** Bug 1803 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2001-09-11 20:26:26 CET -------
Fix checked into Pike 7.2; 7.3 ought to have a more clean fix for this. It
should fix the write problem too.

Note

You need to log in before you can comment on or make changes to this bug.